首页 > Python > 关于在centos下安装python3.7.0以上版本时报错ModuleNotFoundError: No module named ‘_ctypes’的解决办法
2018
09-21

关于在centos下安装python3.7.0以上版本时报错ModuleNotFoundError: No module named ‘_ctypes’的解决办法

3.7版本需要一个新的包libffi-devel,安装此包之后再次进行编译安装即可。
若在安装前移除了/usr/bin下python的文件链接依赖,此时yum无法正常使用,需要自己下载相关软件包安装,为节省读者时间,放上链接
解决方法:

yum -y install libffi-devel

安装完成后重新进行make install,结束后再次配置相关文件的软连接即可。

最后编辑:
作者:劳福喜博客
这个作者貌似有点懒,什么都没有留下。

留下一个回复

This site uses Akismet to reduce spam. Learn how your comment data is processed.